<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" /><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width" />
<title>COVID-19 Sparks Broadway Discounts - Stony Brook Independent</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://sbindependent.org/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://sbindependent.org/wp-content/themes/fearless/js/html5shiv.js" type="text/javascript"></script>
<![endif]-->
<meta name="generator" content="WordPress 5.2.4" />
<meta name="template" content="Fearless - Modern, Clean, &amp; Responsive WP Magazine 1.7.1" />

<meta name="description" content="Stony Brook University News" />
<link rel="canonical" href="https://sbindependent.org/covid-19-sparks-broadway-discounts/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="COVID-19 Sparks Broadway Discounts - Stony Brook Independent" />
<meta property="og:description" content="Stony Brook University News" />
<meta property="og:url" content="https://sbindependent.org/covid-19-sparks-broadway-discounts/" />
<meta property="og:site_name" content="Stony Brook Independent" />
<meta property="article:tag" content="Broadway" />
<meta property="article:tag" content="coronovirus" />
<meta property="article:tag" content="COVID-19" />
<meta property="article:tag" content="discounts" />
<meta property="article:tag" content="Drama" />
<meta property="article:tag" content="theatre" />
<meta property="article:tag" content="tickets" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-03-11T02:31:12+00:00" />
<meta property="article:modified_time" content="2020-03-11T02:31:13+00:00" />
<meta property="og:updated_time" content="2020-03-11T02:31:13+00:00" />
<meta property="og:image" content="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&#038;ssl=1" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="360" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Stony Brook University News" />
<meta name="twitter:title" content="COVID-19 Sparks Broadway Discounts - Stony Brook Independent" />
<meta name="twitter:site" content="@SBINews" />
<meta name="twitter:image" content="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&#038;ssl=1" />
<meta name="twitter:creator" content="@SBINews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://sbindependent.org/#website","url":"https://sbindependent.org/","name":"Stony Brook Independent","publisher":{"@id":"https://sbindependent.org/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://sbindependent.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#webpage","url":"https://sbindependent.org/covid-19-sparks-broadway-discounts/","inLanguage":"en-US","name":"COVID-19 Sparks Broadway Discounts - Stony Brook Independent","isPartOf":{"@id":"https://sbindependent.org/#website"},"image":{"@type":"ImageObject","@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#primaryimage","url":"https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?resize=640%2C360&ssl=1","caption":"Theater District, Midtown Manhattan, NYC"},"primaryImageOfPage":{"@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#primaryimage"},"datePublished":"2020-03-11T02:31:12+00:00","dateModified":"2020-03-11T02:31:13+00:00","description":"Stony Brook University News"},{"@type":"Article","@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#article","isPartOf":{"@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#webpage"},"author":{"@id":"https://sbindependent.org/author/mckenzimurphy/#author","name":"mckenzimurphy"},"publisher":{"@id":"https://sbindependent.org/#organization"},"headline":"COVID-19 Sparks Broadway Discounts","datePublished":"2020-03-11T02:31:12+00:00","dateModified":"2020-03-11T02:31:13+00:00","commentCount":0,"mainEntityOfPage":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#webpage","image":{"@id":"https://sbindependent.org/covid-19-sparks-broadway-discounts/#primaryimage"},"keywords":"Broadway,coronovirus,COVID-19,discounts,Drama,theatre,tickets","articleSection":"Arts &amp; Features,Entertainment,News"},{"@type":"Person","@id":"https://sbindependent.org/author/mckenzimurphy/#author","name":"mckenzimurphy","image":{"@type":"ImageObject","@id":"https://sbindependent.org/#personlogo","url":"https://secure.gravatar.com/avatar/4fe2066159295217df384c9eb77b0d38?s=96&d=mm&r=g","caption":"mckenzimurphy"},"description":"McKenzi Thi Murphy is the Executive Editor of the Independent. A student of the J-School, she is currently in her junior year and also pursuing a secondary major in Women's and Gender Studies, as well as a minor in Theatre. She spends any and all free time seeing theatrical productions and lamenting the rising costs of Broadway. Her life goals are to write a play, maybe, and destroy the patriarchy, definitely.\u00a0","sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//sbindependent.org' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Stony Brook Independent &raquo; Feed" href="https://sbindependent.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Stony Brook Independent &raquo; Comments Feed" href="https://sbindependent.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Stony Brook Independent &raquo; COVID-19 Sparks Broadway Discounts Comments Feed" href="https://sbindependent.org/covid-19-sparks-broadway-discounts/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sbindependent.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flagallery-css' href='https://sbindependent.org/wp-content/plugins/flash-album-gallery/assets/flagallery.css?ver=5.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://sbindependent.org/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://sbindependent.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://sbindependent.org/wp-includes/css/dashicons.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://sbindependent.org/wp-includes/js/thickbox/thickbox.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='auto-thickbox-css' href='https://sbindependent.org/wp-content/plugins/auto-thickbox/css/styles-pre39.css?ver=20140420' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css' href='https://sbindependent.org/wp-content/themes/fearless/fancybox/jquery.fancybox-1.3.4.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='normalize-css' href='https://sbindependent.org/wp-content/themes/fearless/css/normalize.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='fearless-css' href='https://sbindependent.org/wp-content/themes/sbinews2.0/style.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='fearless-responsive-css' href='https://sbindependent.org/wp-content/themes/fearless/css/fearless-responsive.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css?ver=4.0.3' type='text/css' media='all' />

<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='newsletter-css' href='https://sbindependent.org/wp-content/plugins/newsletter/style.css?ver=6.3.5' type='text/css' media='all' />
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/json2.min.js?ver=2015-05-03'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var live_blogging = {"ajaxurl":"https:\/\/sbindependent.org\/wp-admin\/admin-ajax.php","update_effect":"top"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/live-blogging/live-blogging.js?ver=5.2.4'></script>
<link rel='https://api.w.org/' href='https://sbindependent.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sbindependent.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sbindependent.org/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/p5DIme-9Bv' />
<link rel="alternate" type="application/json+oembed" href="https://sbindependent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsbindependent.org%2Fcovid-19-sparks-broadway-discounts%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sbindependent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsbindependent.org%2Fcovid-19-sparks-broadway-discounts%2F&#038;format=xml" />
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next &gt;","prev":"&lt; Prev","image":"Image","of":"of","close":"Close","loadingAnimation":"https:\/\/sbindependent.org\/wp-content\/plugins\/auto-thickbox\/images\/loadingAnimation.gif"};
try{convertEntities(thickboxL10n);}catch(e){};;
/* ]]> */
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Bitter:400|Open+Sans:400,400italic,700" />
<style>
@media only screen and ( max-width: 960px ) {
  #header-background-image-wrapper {
    display: none;
  }
  #header {
    background: url('https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/08/Untitled-3.png') no-repeat top;
    background-size: 100%;
  }
}
@media only screen and ( max-width: 640px ) {
  #header-background-image-wrapper {
    display: none;
  }
  #header {
    background: url('https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/08/Untitled-3.png') no-repeat top;
    background-size: 100%;
  }
}
.button:hover,
.flexslider .category-label,
.layout-module .widget-title > span,
.pagination a:hover,
.pagination .current,
#primary-navigation .menu li.current-menu-item,
#primary-navigation .menu li.current-menu-ancestor,
#primary-navigation .menu li.current_page_item,
#primary-navigation .menu > li:hover,
#primary-navigation .menu > li.sfHover,
#primary-navigation .menu ul a:hover,
#primary-navigation .menu ul li.current-menu-item a,
.review-box .heading,
#searchform #searchsubmit:hover,
#secondary .widget_fearless_tabs .headings a:hover,
#secondary .widget_fearless_tabs .headings a.active,
section.top-reviews .review-column-1 h2,
.sidebar-primary .widget-title,
.wpcf7-submit:hover
{ background-color: #a91515; }
.fearless-star-rating-over {
color: #a91515; }
#topbar,
.widget_archive ul li:hover,
.widget_categories ul li:hover,
#primary-navigation,
#primary-navigation .menu > li > ul,
.featured-slider.flexslider .category-label-wrapper,
.layout-module .widget-title {
border-color: #a91515; }
a { color: #21759b; }
a:hover, a:focus, a:active { color: #a91515; }
#topbar { background-color: #222222; }
#primary-navigation,
#primary-navigation .menu ul,
#primary-navigation select.tinynav { background-color: #222222; }
#footer { background-color: #222222; }
html { font-size: 62.5%; }
body, #menubar-search-query, .review-box .heading, .review-box .short-summary { font-family: "Open Sans"; }

.entry-content h1,
.entry-content h2,
.entry-content h3,
.entry-content h4,
.entry-content h5,
.entry-content h6,
.entry-title { font-family: "Bitter"; font-weight: 400; }
</style>
<script>
jQuery(document).ready(function($){
	$('#primary-navigation > ul, #secondary-navigation > ul').tinyNav({
		active: 'current-menu-item',
		header: 'Menu'
	});
});
</script>
</head>
<body class="wordpress ltr en_US child-theme multisite blog-23 y2020 m03 d12 h13 thursday logged-out singular singular-post singular-post-36921 post-format-standard topbar-enabled logo-image-enabled layout-2c-l">
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-11395905-11', 'auto');
  ga('send', 'pageview');

</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div id="container" class="hfeed">
<div id="topbar"><div class="topbar-left breadcrumb-trail">
<div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb">
<span class="trail-browse">Browse:</span> <span class="trail-begin"><a href="https://sbindependent.org" title="Stony Brook Independent" rel="home">Home</a></span>
<span class="sep">&#47;</span> <span class="trail-end">COVID-19 Sparks Broadway Discounts</span>
</div></div><div class="topbar-right secondary_navigation"><nav id="secondary-navigation" role="navigation">
<h1 class="screen-reader-text">Menu</h1>
<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
<ul id="menu-upper-menu" class="menu"><li id="menu-item-6755" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6755"><a href="https://sbindependent.org/send-us-a-tip/">Send Us A Tip</a></li>
</ul></nav></div></div>
<header id="header" role="banner">
<div id="header-background-image-wrapper"><img src="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/08/Untitled-3.png" id="header-background-image" alt="Header image" width="" height="" /></div>
<div id="branding">
<h1 id="site-title"><a href="https://sbindependent.org/" rel="home"><span>Stony Brook Independent</span><img src="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/11/SBIndie-logo.png" alt="Logo" width="" height="" /></a></h1>
<h2 id="site-description">Stony Brook University News</h2>
</div>
<nav id="primary-navigation" role="navigation">
<h3 class="screen-reader-text">Menu</h3>
<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
<ul id="menu-main-menu" class="menu sf-menu"><li id="menu-item-6748" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-6748"><a href="https://sbindependent.org/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-24866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24866"><a href="https://sbindependent.org/news/health-science/">Health &#038; Science</a></li>
<li id="menu-item-25760" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25760"><a href="https://sbindependent.org/news/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-6751" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-6751"><a href="https://sbindependent.org/arts/">Reviews</a>
<ul class="sub-menu">
<li id="menu-item-24863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24863"><a href="https://sbindependent.org/arts/reviews-2/movie-reviews/">Movie Reviews</a></li>
<li id="menu-item-24864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24864"><a href="https://sbindependent.org/arts/reviews-2/album-reviews/">Music Reviews</a></li>
<li id="menu-item-32461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32461"><a href="https://sbindependent.org/arts/reviews-2/game-reviews/">Game Reviews</a></li>
</ul>
</li>
<li id="menu-item-6750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6750"><a href="https://sbindependent.org/op-ed/">Blogs</a></li>
<li id="menu-item-24860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24860"><a href="https://sbindependent.org/listicles/">Listicles</a></li>
<li id="menu-item-36304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36304"><a href="https://sbindependent.org/multimedia/">Multimedia</a></li>
<li id="menu-item-6754" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6754"><a href="https://sbindependent.org/about/">About Us</a>
<ul class="sub-menu">
<li id="menu-item-6769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6769"><a href="https://sbindependent.org/staff/">Staff Bios</a></li>
<li id="menu-item-28667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28667"><a href="https://sbindependent.org/newsletter/">Newsletter</a></li>
<li id="menu-item-10109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10109"><a href="https://sbindependent.org/subscribe/">Subscribe</a></li>
<li id="menu-item-30236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30236"><a href="https://sbindependent.org/advertising/">Advertising</a></li>
<li id="menu-item-6770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6770"><a href="https://sbindependent.org/send-us-a-tip/">Send Us A Tip</a></li>
</ul>
</li>
</ul>
<form id="menubar-search" method="get" action="https://sbindependent.org/" role="search" class="fa fa-search">
<label for="menubar-search-submit" class="screen-reader-text">Search</label>
<input type="search" id="menubar-search-query" name="s" value="" placeholder="Search&hellip;" />
<input type="submit" id="menubar-search-submit" value="Go" />
</form>
</nav>
<div id="ticker">
<ul id="js-news">
<li class="news-item"><a href="https://sbindependent.org/covid-19-sparks-broadway-discounts/">COVID-19 Sparks Broadway Discounts</a></li>
<li class="news-item"><a href="https://sbindependent.org/stony-brook-women-basketball-team-continue-their-21-game-win-streak-with-a-win-over-rivals-binghamton-58-54/">Stony Brook Women Basketball team continue their 21 game win streak with a win over rivals Binghamton (58-54)</a></li>
<li class="news-item"><a href="https://sbindependent.org/sbu-kicks-off-black-history-month-with-a-conversation-with-spike-lee/">SBU kicks off Black History Month with a Conversation with Spike Lee</a></li>
<li class="news-item"><a href="https://sbindependent.org/why-we-should-rethink-juicing-how-we-can-make-it-healthier/">Why We Should Rethink Juicing (& How We Can Make It Healthier)</a></li>
<li class="news-item"><a href="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/">The Great White Way’s Efforts to Go Green</a></li>
</ul>
</div>
</header>
<div id="main">
<div class="addthis_toolbox addthis_floating_style addthis_counter_style sharebar">
<a class="addthis_button_facebook_like" fb:like:layout="box_count"></a>
<a class="addthis_button_tweet" tw:count="vertical"></a>
<a class="addthis_button_google_plusone" g:plusone:size="tall"></a>
<a class="addthis_counter"></a>
</div>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=xa-515b250428f60d54"></script>
<div id="primary">
<div id="content" class="hfeed" role="main">
<article id="post-36921" class="hentry post publish post-1 odd author-mckenzimurphy format-standard category-arts category-entertainment-2 category-news post_tag-broadway post_tag-coronovirus post_tag-covid-19 post_tag-discounts post_tag-drama post_tag-theatre post_tag-tickets">
<header class="entry-header">
<div class="post-thumbnail-wrap"><img width="640" height="360" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?resize=640%2C360&amp;ssl=1" class="attachment-post-thumbnail featured-image wp-post-image" alt="" data-attachment-id="36922" data-permalink="https://sbindependent.org/covid-19-sparks-broadway-discounts/theater-district-midtown-manhattan-nyc/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;@Epicsunwarrior&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Theater District, Midtown Manhattan, NYC&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Ajay Suresh&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Theater District, Midtown Manhattan, NYC&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Theater District, Midtown Manhattan, NYC" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&amp;ssl=1" /></div>
<h1 class="entry-title">COVID-19 Sparks Broadway Discounts</h1>
<div class="entry-byline">Posted by <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/mckenzimurphy/" title="mckenzimurphy">mckenzimurphy</a></span> on <time class="published" datetime="2020-03-10T22:31:12-04:00" title="Tuesday, March 10th, 2020, 10:31 pm">March 10, 2020</time> in <span class="category"><a href="https://sbindependent.org/arts/" rel="tag">Arts &amp; Features</a>, <a href="https://sbindependent.org/entertainment-2/" rel="tag">Entertainment</a>, <a href="https://sbindependent.org/news/" rel="tag">News</a></span> | 31 Views | <a class="comments-link" href="https://sbindependent.org/covid-19-sparks-broadway-discounts/#respond" title="Comment on COVID-19 Sparks Broadway Discounts">Leave a response</a></div> </header>
<div class="entry-content">
<p>Written by McKenzi Thi Murphy</p>
<p><em>Editor-in-Chief</em></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Earlier today, in a press release sent out to all theatre news outlets, Broadway producer Scott Rudin announced that beginning March 12 at noon, all remaining tickets to his shows would be available for the unheard-of price of just $50. The last time average ticket prices went</span> <span style="font-weight: 400;">for</span><span style="font-weight: 400;"> this low an amount was in 1998, over 20 years ago, according to data from The Broadway League.</span></p>
<p><span style="font-weight: 400;">“As long as New York City is open for business, its beating heart remains the Broadway stage,” Rudin said in the release. “This is an unprecedented opportunity for everyone to see a show that they otherwise might not have had easy and affordable access to. I can’t pretend that great theater is the panacea we’ve been waiting for, but in the meantime I think we could all use a few hours away from the evening news.”</span></p>
<p><span style="font-weight: 400;">The shows in question include </span><i><span style="font-weight: 400;">The Book of Mormon, The Lehman Trilogy, To Kill a Mockingbird, West Side Story, </span></i><span style="font-weight: 400;">and </span><i><span style="font-weight: 400;">Who’s Afraid of Virginia Woolf</span></i><span style="font-weight: 400;">, and the offer extends through March 29.</span></p>
<p><span style="font-weight: 400;">But while the thought of paying just $50 for a potential front orchestra seat is very tempting, and may seem like a bright light amid the chaos and confusion, this discount also seems a little tone-deaf considering many health officials are warning people away from packed gatherings. As of today, New York has seen 173 confirmed cases of coronavirus, 36 in New York City. </span></p>
<p><span style="font-weight: 400;">Of course, some people took to Twitter to express their discontent, including several in the industry. </span></p>
<p><span style="font-weight: 400;">“A pandemic shouldn’t inspire “affordable tickets,” tweeted Jeremy O. Harris, an up-and-coming playwright who premiered his first Broadway show, </span><i><span style="font-weight: 400;">Slave Play, </span></i><span style="font-weight: 400;">back in November. “What’s wrong w/ y’all?” He later followed up the Tweet by saying, “I’m not trying to [expletive] on any parades, but after YEARS of the most successful commercial theatre makers throwing up their hands and saying “there’s nothing we can do abt it,” it’s startling to see a clearance sale being presented as a gift in the face of [skull emoji] and economic collapse.”</span></p>
<p><span style="font-weight: 400;">In light of fears surrounding COVID-19 (coronavirus), Broadway grosses have taken a slight downturn in the past few weeks, and ticket averages were just over $105 last week. Given how prices have been increasingly skyrocketing in the past several years (top musical prices can be over $500) this is quite the change. Given how a crowded theater filled with a thousand other people all packed in like sardines seems like the opposite of what is being recommended, this is not shocking. </span></p>
<p><span style="font-weight: 400;">The addition of six new shows beginning previews last week has kept grosses relatively up, all things considered. Marianne Elliot’s new production of </span><i><span style="font-weight: 400;">Company</span></i><span style="font-weight: 400;">, a Sondheim classic, was at over 100% capacity, as were several other popular shows such as </span><i><span style="font-weight: 400;">Hamilton </span></i><span style="font-weight: 400;">and </span><i><span style="font-weight: 400;">Hadestown. </span></i><span style="font-weight: 400;"> However, some of Rudin’s shows, such as </span><i><span style="font-weight: 400;">The Book of Mormon,</span></i><span style="font-weight: 400;"> have seen ever-so-slight dips since the global issue touched closer to home, though no lower than the numbers of late-January and February, normally slower months for Broadway.</span></p>
<p><span style="font-weight: 400;">While some shows have elected to temporarily suspend the practice of stage dooring to minimize contact with actors, and sustained gatherings, there has been no indication Broadway had any intention of closing its doors just yet, and with these discounts now in place for select shows, clearly quite the opposite is happening. </span></p>
</div>
<footer class="entry-footer">
<div class="entry-meta"><span class="category"><span class="before">Posted in </span><a href="https://sbindependent.org/arts/" rel="tag">Arts &amp; Features</a>, <a href="https://sbindependent.org/entertainment-2/" rel="tag">Entertainment</a>, <a href="https://sbindependent.org/news/" rel="tag">News</a></span> <span class="post_tag"><span class="before">| Tagged </span><a href="https://sbindependent.org/tag/broadway/" rel="tag">Broadway</a>, <a href="https://sbindependent.org/tag/coronovirus/" rel="tag">coronovirus</a>, <a href="https://sbindependent.org/tag/covid-19/" rel="tag">COVID-19</a>, <a href="https://sbindependent.org/tag/discounts/" rel="tag">discounts</a>, <a href="https://sbindependent.org/tag/drama/" rel="tag">Drama</a>, <a href="https://sbindependent.org/tag/theatre/" rel="tag">theatre</a>, <a href="https://sbindependent.org/tag/tickets/" rel="tag">tickets</a></span></div> </footer>
</article>
<aside class="authorbox">
<h2 class="authorbox-title">About the Author</h2>
<a class="authorbox-avatar" href="https://sbindependent.org/author/mckenzimurphy/">
</a>
<h3><a class="authorbox-author-url" href="https://sbindependent.org/author/mckenzimurphy/">mckenzimurphy</a></h3>
<p>McKenzi Thi Murphy is the Executive Editor of the Independent. A student of the J-School, she is currently in her junior year and also pursuing a secondary major in Women&#8217;s and Gender Studies, as well as a minor in Theatre. She spends any and all free time seeing theatrical productions and lamenting the rising costs of Broadway. Her life goals are to write a play, maybe, and destroy the patriarchy, definitely. </p>
<ul class="author-social-profiles">
</ul>
</aside>
<aside class="related-posts">
<h2 class="related-posts-header">Related Posts</h2><article class="related-post related-post-1 related-by-tag"><h3><a href="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/"><img width="232" height="150" src="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=232%2C150&amp;ssl=1" class="attachment-thumb-232 size-thumb-232 wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=232%2C150&amp;ssl=1 232w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?zoom=2&amp;resize=232%2C150&amp;ssl=1 464w" sizes="(max-width: 232px) 100vw, 232px" data-attachment-id="36895" data-permalink="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/theater/" data-orig-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="theater" data-image-description="" data-medium-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=640%2C360&amp;ssl=1" />The Great White Way’s Efforts to Go Green<span class="arrow">&rarr;</span></a></h3></article><article class="related-post related-post-2 related-by-tag"><h3><a href="https://sbindependent.org/ring-of-keys-unlocking-doors-for-the-queer-community/"><img width="232" height="150" src="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?resize=232%2C150&amp;ssl=1" class="attachment-thumb-232 size-thumb-232 wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?resize=232%2C150&amp;ssl=1 232w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?zoom=2&amp;resize=232%2C150&amp;ssl=1 464w" sizes="(max-width: 232px) 100vw, 232px" data-attachment-id="36828" data-permalink="https://sbindependent.org/ring-of-keys-unlocking-doors-for-the-queer-community/ring/" data-orig-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;DroughtofApathy&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1571755750&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ring" data-image-description="" data-medium-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Ring.jpg?fit=640%2C360&amp;ssl=1" />Ring of Keys: Unlocking Doors for the Queer Community<span class="arrow">&rarr;</span></a></h3></article><article class="related-post related-post-3 related-by-tag"><h3><a href="https://sbindependent.org/not-your-grandmothers-theatre-slave-play-review/"><img width="232" height="150" src="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?resize=232%2C150&amp;ssl=1" class="attachment-thumb-232 size-thumb-232 wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?resize=232%2C150&amp;ssl=1 232w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?zoom=2&amp;resize=232%2C150&amp;ssl=1 464w" sizes="(max-width: 232px) 100vw, 232px" data-attachment-id="36810" data-permalink="https://sbindependent.org/not-your-grandmothers-theatre-slave-play-review/slave-play/" data-orig-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Slave Play" data-image-description="" data-medium-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/10/Slave-Play.jpg?fit=640%2C360&amp;ssl=1" />Not Your Grandmother&#8217;s Theatre: &#8220;Slave Play&#8221; Review<span class="arrow">&rarr;</span></a></h3></article><article class="related-post related-post-4 related-by-tag"><h3><a href="https://sbindependent.org/tony-award-nominations-2018-2019-snubs-and-sweeps/"><img width="232" height="150" src="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?resize=232%2C150&amp;ssl=1" class="attachment-thumb-232 size-thumb-232 wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?resize=232%2C150&amp;ssl=1 232w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?zoom=2&amp;resize=232%2C150&amp;ssl=1 464w" sizes="(max-width: 232px) 100vw, 232px" data-attachment-id="36754" data-permalink="https://sbindependent.org/tony-award-nominations-2018-2019-snubs-and-sweeps/tony-awards-logo-blue/" data-orig-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?fit=620%2C360&amp;ssl=1" data-orig-size="620,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Tony-Awards-logo-blue" data-image-description="" data-medium-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?fit=300%2C174&amp;ssl=1" data-large-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/04/Tony-Awards-logo-blue.jpg?fit=620%2C360&amp;ssl=1" />Tony Award Nominations 2018-2019: Snubs and Sweeps<span class="arrow">&rarr;</span></a></h3></article>
</aside>
<section id="comments" class="comments-type-">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/covid-19-sparks-broadway-discounts/#respond" style="display:none;">Cancel Reply</a></small></h3> <form action="https://sbindependent.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="form-textarea req"><label for="comment">Comment</label><textarea name="comment" id="comment" cols="60" rows="10"></textarea></p><p class="form-author req"><label for="author">Name <span class="required">*</span> </label> <input type="text" class="text-input" name="author" id="author" value="" size="40" /></p>
<p class="form-email req"><label for="email">Email <span class="required">*</span> </label> <input type="email" class="text-input" name="email" id="email" value="" size="40" /></p>
<p class="form-url"><label for="url">Website</label><input type="url" class="text-input" name="url" id="url" value="" size="40" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='36921' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7a0651aa6a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="231" /></p> </form>
</div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</section>
</div>
</div>
<aside id="secondary" class="widget-area sidebar-primary" role="complementary">
<section id="fearless_social_icons-2" class="widget widget_fearless_social_icons"><ul class="social-icons"><li><a href="https://www.facebook.com/sbinews" class="background-color-facebook" title="Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i><span class="screen-reader-text">Facebook</span></a></li><li><a href="https://instagram.com/stonybrookindie" class="background-color-instagram" title="Instagram" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i><span class="screen-reader-text">Instagram</span></a></li><li><a href="/feed/" class="background-color-rss" title="RSS Feed" target="_blank"><i class="fa fa-rss" aria-hidden="true"></i><span class="screen-reader-text">RSS Feed</span></a></li><li><a href="https://www.twitter.com/stonybrookindie" class="background-color-twitter" title="Twitter" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i><span class="screen-reader-text">Twitter</span></a></li></ul></section><section id="fearless_tabs-3" class="widget widget_fearless_tabs"> <ul class="headings clearfix">
<li class="tab1"><a class="widget-title active" href="#">Latest</a></li>
<li class="tab2"><a class="widget-title" href="#">Top Rated</a></li>
<li class="tab3"><a class="widget-title" href="#">Trending</a></li>
</ul>
<div class="widgets">
<div class="tab1 recent"><ul class="teaser-list"> <li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/covid-19-sparks-broadway-discounts/"><img width="55" height="55" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" data-attachment-id="36922" data-permalink="https://sbindependent.org/covid-19-sparks-broadway-discounts/theater-district-midtown-manhattan-nyc/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;@Epicsunwarrior&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Theater District, Midtown Manhattan, NYC&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Ajay Suresh&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Theater District, Midtown Manhattan, NYC&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Theater District, Midtown Manhattan, NYC" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/03/Discount.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/covid-19-sparks-broadway-discounts/">COVID-19 Sparks Broadway Discounts</a></h2>
<div class="byline">
<time class="published" datetime="2020-03-10T22:31:12-04:00" title="Tuesday, March 10th, 2020, 10:31 pm">March 10, 2020</time> / <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/mckenzimurphy/" title="mckenzimurphy">mckenzimurphy</a></span> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/stony-brook-women-basketball-team-continue-their-21-game-win-streak-with-a-win-over-rivals-binghamton-58-54/"><img width="55" height="55" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/DSC_0955-1.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" data-attachment-id="36913" data-permalink="https://sbindependent.org/stony-brook-women-basketball-team-continue-their-21-game-win-streak-with-a-win-over-rivals-binghamton-58-54/dsc_0955-1/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/DSC_0955-1.jpg?fit=4233%2C2816&amp;ssl=1" data-orig-size="4233,2816" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/DSC_0955-1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/DSC_0955-1.jpg?fit=640%2C426&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/stony-brook-women-basketball-team-continue-their-21-game-win-streak-with-a-win-over-rivals-binghamton-58-54/">Stony Brook Women Basketball team continue their 21 game win streak with a win over rivals Binghamton (58-54)</a></h2>
<div class="byline">
<time class="published" datetime="2020-02-16T20:10:25-04:00" title="Sunday, February 16th, 2020, 8:10 pm">February 16, 2020</time> / <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/vaidiktrivedi/" title="vaidiktrivedi">vaidiktrivedi</a></span> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/sbu-kicks-off-black-history-month-with-a-conversation-with-spike-lee/"><img width="55" height="55" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/rsz_200205_spike_lee_lecture_239.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" data-attachment-id="36910" data-permalink="https://sbindependent.org/sbu-kicks-off-black-history-month-with-a-conversation-with-spike-lee/rsz_200205_spike_lee_lecture_239/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/rsz_200205_spike_lee_lecture_239.jpg?fit=1024%2C683&amp;ssl=1" data-orig-size="1024,683" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;John Griffin\/SBU Communications&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark IV&quot;,&quot;caption&quot;:&quot;Stony Brook, NY; Stony Brook University: \tFilmmaker Spike Lee was the guest speaker at the Presidential Lecture Series to kick off the annual Black History Month Observance at Stony Brook University.&quot;,&quot;created_timestamp&quot;:&quot;1580929829&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;170&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/rsz_200205_spike_lee_lecture_239.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2020/02/rsz_200205_spike_lee_lecture_239.jpg?fit=640%2C427&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/sbu-kicks-off-black-history-month-with-a-conversation-with-spike-lee/">SBU kicks off Black History Month with a Conversation with Spike Lee</a></h2>
<div class="byline">
<time class="published" datetime="2020-02-11T18:34:36-04:00" title="Tuesday, February 11th, 2020, 6:34 pm">February 11, 2020</time> / <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/vaidiktrivedi/" title="vaidiktrivedi">vaidiktrivedi</a></span> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/why-we-should-rethink-juicing-how-we-can-make-it-healthier/"><img width="55" height="55" src="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/12/Juicing.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" data-attachment-id="36903" data-permalink="https://sbindependent.org/why-we-should-rethink-juicing-how-we-can-make-it-healthier/juicing/" data-orig-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/12/Juicing.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D7000&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1391863731&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;105&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.02&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Juicing" data-image-description="" data-medium-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/12/Juicing.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/12/Juicing.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/why-we-should-rethink-juicing-how-we-can-make-it-healthier/">Why We Should Rethink Juicing (&#038; How We Can Make It Healthier)</a></h2>
<div class="byline">
<time class="published" datetime="2019-12-30T18:27:22-04:00" title="Monday, December 30th, 2019, 6:27 pm">December 30, 2019</time> / <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/guest/" title="guest">guest</a></span> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/"><img width="55" height="55" src="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=83%2C83&amp;ssl=1 83w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=55%2C55&amp;ssl=1 55w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?resize=60%2C60&amp;ssl=1 60w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="36895" data-permalink="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/theater/" data-orig-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="theater" data-image-description="" data-medium-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2019/11/theater.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/the-great-white-ways-efforts-to-go-green/">The Great White Way’s Efforts to Go Green</a></h2>
<div class="byline">
<time class="published" datetime="2019-11-18T22:31:06-04:00" title="Monday, November 18th, 2019, 10:31 pm">November 18, 2019</time> / <span class="author vcard"><a class="url fn n" rel="author" href="https://sbindependent.org/author/mckenzimurphy/" title="mckenzimurphy">mckenzimurphy</a></span> </div>
</li>
</ul></div>
<div class="tab2 top_rated"><ul class="teaser-list"> <li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/kylie-minogues-new-album-kiss-said/"><img width="55" height="55" src="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?resize=83%2C83&amp;ssl=1 83w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?resize=55%2C55&amp;ssl=1 55w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?resize=60%2C60&amp;ssl=1 60w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="18304" data-permalink="https://sbindependent.org/kylie-minogues-new-album-kiss-said/admin-ajax-php-2-2/" data-orig-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="admin-ajax.php-2" data-image-description="" data-medium-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/admin-ajax.php-2.jpeg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/kylie-minogues-new-album-kiss-said/">On Kylie Minogue&#8217;s New Album, &#8220;Kiss Me Once&#8221; Was All She Said</a></h2>
<div class="byline">
<div class="fearless-star-rating-wrapper"><span class="fearless-star-rating-under"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span><span class="fearless-star-rating-over" style="clip: rect(0, 20000em, 1em, 0);"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span></div> </div>
</li>
<li>
 <div class="post-thumbnail-wrap"><a href="https://sbindependent.org/divergent-hits-mark/"><img width="55" height="55" src="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?resize=83%2C83&amp;ssl=1 83w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?resize=55%2C55&amp;ssl=1 55w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?resize=60%2C60&amp;ssl=1 60w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="18445" data-permalink="https://sbindependent.org/divergent-hits-mark/divergent-movie-640x360/" data-orig-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Divergent-Movie-640&#215;360" data-image-description="" data-medium-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i1.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Divergent-Movie-640x360.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/divergent-hits-mark/">&#8216;Divergent&#8217; Hits its Mark</a></h2>
<div class="byline">
<div class="fearless-star-rating-wrapper"><span class="fearless-star-rating-under"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span><span class="fearless-star-rating-over" style="clip: rect(0, 2000em, 1em, 0);"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span></div> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/7-reasons-watch-captain-america-winter-soldier/"><img width="55" height="55" src="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?resize=83%2C83&amp;ssl=1 83w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?resize=55%2C55&amp;ssl=1 55w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?resize=60%2C60&amp;ssl=1 60w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="18608" data-permalink="https://sbindependent.org/7-reasons-watch-captain-america-winter-soldier/captain-america-the-winter-soldier1/" data-orig-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1395611548&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Captain-America-The-Winter-Soldier1" data-image-description="" data-medium-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/04/Captain-America-The-Winter-Soldier1.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/7-reasons-watch-captain-america-winter-soldier/">7 Reasons To Watch Captain America: The Winter Soldier</a></h2>
<div class="byline">
<div class="fearless-star-rating-wrapper"><span class="fearless-star-rating-under"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span><span class="fearless-star-rating-over" style="clip: rect(0, 100em, 1em, 0);"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span></div> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/long-see-tomorrow-music-today/"><img width="55" height="55" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?zoom=2&amp;resize=55%2C55&amp;ssl=1 110w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="17406" data-permalink="https://sbindependent.org/long-see-tomorrow-music-today/bbc/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?fit=640%2C359&amp;ssl=1" data-orig-size="640,359" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="bbc" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/02/bbc-e1393286014621.jpg?fit=640%2C359&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/long-see-tomorrow-music-today/">Bombay Bicycle Club Is Back With A Bang</a></h2>
<div class="byline">
<div class="fearless-star-rating-wrapper"><span class="fearless-star-rating-under"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span><span class="fearless-star-rating-over" style="clip: rect(0, 80em, 1em, 0);"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span></div> </div>
</li>
<li>
<div class="post-thumbnail-wrap"><a href="https://sbindependent.org/need-speed-tries-hard-misses-finish-line/"><img width="55" height="55" src="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?resize=55%2C55&amp;ssl=1" class="attachment-thumb-55 featured-image wp-post-image" alt="" srcset="https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?resize=83%2C83&amp;ssl=1 83w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?resize=55%2C55&amp;ssl=1 55w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?resize=60%2C60&amp;ssl=1 60w, https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?zoom=3&amp;resize=55%2C55&amp;ssl=1 165w" sizes="(max-width: 55px) 100vw, 55px" data-attachment-id="18175" data-permalink="https://sbindependent.org/need-speed-tries-hard-misses-finish-line/need-for-speed-poster/" data-orig-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?fit=640%2C360&amp;ssl=1" data-orig-size="640,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Need for Speed Poster" data-image-description="" data-medium-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i2.wp.com/cdn.totalcomputersusa.com/managed/uploads/sites/23/2014/03/Need-for-Speed-Poster.jpg?fit=640%2C360&amp;ssl=1" /></a></div>
<h2 class="title"><a href="https://sbindependent.org/need-speed-tries-hard-misses-finish-line/">&#8216;Need for Speed&#8217; Tries Hard, Misses Finish Line</a></h2>
<div class="byline">
<div class="fearless-star-rating-wrapper"><span class="fearless-star-rating-under"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span><span class="fearless-star-rating-over" style="clip: rect(0, 20em, 1em, 0);"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i></span></div> </div>
</li>
</ul></div>
<div class="tab3 facebook"><div class="fb-like-box" data-href="https://www.facebook.com/sbinews" data-width="300" data-show-faces="true" data-stream="true" data-show-border="false" data-header="false"></div></div>
</div>
</section><section id="text-22" class="widget widget_text"><h1 class="widget-title"><span>Advertisement</span></h1> <div class="textwidget"><div style="text-align:center;">
<a href=" http://strose.edu/saint-rose-graduate ">
<img src=" https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/11/Screen-Shot-2015-11-17-at-9.38.31-PM.png " />
</a>
</div></div>
</section><section id="fearless_featured_video-4" class="widget widget_fearless_featured_video"><h1 class="widget-title"><span>Featured Video</span></h1><div class="fitvids"><iframe width="560" height="315" src="https://www.youtube.com/embed/n8289NnGG2M" frameborder="0" allowfullscreen></iframe></div></section><section id="newsletterwidget-4" class="widget widget_newsletterwidget"><h1 class="widget-title"><span>Subscribe</span></h1>Want everything to just be sent right to you? Sign up for our newsletter. Don't forget to check your spam. Thanks!
<div class="tnp tnp-widget"><form method="post" action="https://sbindependent.org/?na=s" onsubmit="return newsletter_check(this)">
<input type="hidden" name="nlang" value="">
<input type="hidden" name="nr" value="widget">
<input type='hidden' name='nl[]' value='0'>
<div class="tnp-field tnp-field-firstname"><label>Name</label><input class="tnp-firstname" type="text" name="nn" required></div>
<div class="tnp-field tnp-field-lastname"><label>Last name</label><input class="tnp-lastname" type="text" name="ns" required></div>
<div class="tnp-field tnp-field-email"><label>Email</label><input class="tnp-email" type="email" name="ne" required></div>
<div class="tnp-field tnp-field-button"><input class="tnp-submit" type="submit" value="Subscribe">
</div>
</form>
</div>
</section><section id="text-23" class="widget widget_text"><h1 class="widget-title"><span>Advertisement</span></h1> <div class="textwidget"><div style="text-align:center;">
<a href=" http://swimrock.com ">
<img src=" https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/09/@swimbandny-1.jpg " />
</a>
</div></div>
</section>
</aside>
</div>
<footer id="footer" role="contentinfo">
<div class="widget-area footer-widget-area">
<div class="column">
<section id="text-4" class="widget widget_text"><h1 class="widget-title"><span>Contact Us!</span></h1> <div class="textwidget"><p>Like what you see? Or don't? Either way, let us know during our weekly general meetings on Wednesday nights at 6:30.</p>
</p>
</p>
<p>We're located in 307L in the Student Activities Center media wing.</p>
</p>
</p>
<p> Have a story idea you want to write, or want to take a pitch from our Facebook page? Email <a href="/cdn-cgi/l/email-protection#5f2c3d36313b3a2f3a313b3a312b1f38323e3633713c3032"><span class="__cf_email__" data-cfemail="e89b8a81868c8d988d868c8d869ca88f85898184c68b8785">[email&#160;protected]</span></a> with questions, concerns or qualms.</p>
</div>
</section>&nbsp;
</div>
<div class="column">
<section id="facebook-likebox-7" class="widget widget_facebook_likebox"><h1 class="widget-title"><span><a href="https://www.facebook.com/SBInews/">Add us on Facebook</a></span></h1> <div id="fb-root"></div>
<div class="fb-page" data-href="https://www.facebook.com/SBInews/" data-width="340" data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/SBInews/"><a href="https://www.facebook.com/SBInews/">Add us on Facebook</a></blockquote></div>
</div>
</section>&nbsp;
</div>
<div class="column">
<section id="twitter_timeline-8" class="widget widget_twitter_timeline"><h1 class="widget-title"><span>Follow us on Twitter</span></h1><a class="twitter-timeline" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="1" data-lang="EN" data-partner="jetpack" href="https://twitter.com/StonyBrookIndie" href="https://twitter.com/StonyBrookIndie">My Tweets</a></section>&nbsp;
</div>
<div class="column">
&nbsp;
</div>
</div>
<p class="footer-copyright footer-left">©2018 Stony Brook Independent</p>
<nav id="footer-navigation" class="footer-right" role="navigation">
<h1 class="screen-reader-text">Menu</h1>
<ul id="menu-upper-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6755"><a href="https://sbindependent.org/send-us-a-tip/">Send Us A Tip</a></li>
</ul></nav>
</footer>
</div>
<div style="display:none">
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
	jQuery(document).ready(function($){
		$.backstretch(
			"https://cdn.totalcomputersusa.com/managed/uploads/sites/23/2015/11/Simple-Navy-Blue-Wedding-Cupcakes-picture-LXie.jpg",
			{ fade: 350 }
		);
	});
</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://sbindependent.org/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "d8daea190b", post_id : 36921 } ); } ); /* ]]> */</script>
<script type='text/javascript'>
/* <![CDATA[ */
var FlaGallery = {"ajaxurl":"https:\/\/sbindependent.org\/wp-admin\/admin-ajax.php","nonce":"be88dc4630","license":"","pack":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/flash-album-gallery/assets/script.js?ver=5.5.5'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.0.0'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://sbindependent.org/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://sbindependent.org/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://sbindependent.org/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://sbindependent.org/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/dist/dom-ready.min.js?ver=2.2.0'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20190901'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"sbinews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"36921 https:\/\/sbindependent.org\/?p=36921","disqusShortname":"sbinews","disqusTitle":"COVID-19 Sparks Broadway Discounts","disqusUrl":"https:\/\/sbindependent.org\/covid-19-sparks-broadway-discounts\/","postId":"36921"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/sbindependent.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.4'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/auto-thickbox/js/auto-thickbox.min.js?ver=20150514'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.backstretch.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/comment-reply.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/fancybox/jquery.fancybox-1.3.4.pack.js?ver=1.3.4'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.fitvids.min.js?ver=5.2.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fearless_localized_strings = {"ticker_title":"Latest News"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/fearless.js?ver=2.0'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.flexslider.min.js?ver=2.1'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.hoverIntent.min.js?ver=r7'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.superfish.min.js?ver=1.6.9'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.ticker.js?ver=2.0'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/themes/fearless/js/jquery.tinynav.min.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sbindependent.org/wp-content/plugins/newsletter/subscription/validate.js?ver=6.3.5'></script>
<script type='text/javascript' src='https://sbindependent.org/wp-includes/js/wp-embed.min.js?ver=5.2.4'></script>
<script async="async" type='text/javascript' src='https://sbindependent.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'83346986',post:'36921',tz:'-4',srv:'sbindependent.org'} ]);
	_stq.push([ 'clickTrackerInit', '83346986', '36921' ]);
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"6e7c500c04","applicationID":"26850365,26896093","transactionName":"YwZabUVVDxdZU0NcWFpMeVpDXQ4KF1lZUVJM","queueTime":0,"applicationTime":7073,"atts":"T0FZGw1PHBk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
